Robots w/Lasers

May 7, 2007

Updates for Flex Builder 2 on Linux

If you are looking to run Flex Builder 2 on Linux, see my original post.

I’ve made two minor updates for people using Flex Builder 2 on Linux. The first is to eliminate the annoying “Incorrect flash player installed…you have 0.0.0.0, and need 9.0.0.0” that pops up every time you run a project. To fix it:

  1. Download debugui.jar
  2. Overwrite the file eclipse/plugins/com.adobe.flexbuilder.debug.ui_2.0.155577/debugui.jar with the downloaded one

The second minor update: I’ve noticed some very annoying bugs in the linux flash player (all reported to Adobe now of course), but in the mean time, I’ve been using the windows flash player under WINE, which does not have the same bugs. If you want to do this (which will probably greatly reduce performance), all you really need is to:Watch movie online A Cure for Wellness (2017)

  1. Make sure you have WINE installed correctly
  2. Download the windows standalone projector debugger
  3. Write a wrapper script that calls wine on the windows .exe, this wrapper will then be called by flex builder. You can see my sampe script to start (it’s very simple, just need to adjust for your paths/filenames).

In other news, I’m working on my first AS3 application that is above the tech-demo level! Well…so far haven’t gotten much, but I’ve got code that compiles on both Linux Flex Builder 2, as well as Windows FlashDevelop, with no changes (yay!). You can see what I have so far, but not it’s not very exciting yet.

Filed under: Flash,flex — davr @ 12:08 am

Powered by WordPress

Bad Behavior has blocked 938 access attempts in the last 7 days.